首页 » 安全预警 » 正文

【高危安全通告】Apache Tomcat Session 反序列化代码执行漏洞(CVE-2020-9484)

2020年5月20日 ,Apache Tomcat官方发布安全公告,披露了一个通过持久化Session可能导致远程代码执行的漏洞CVE-2020-9484。


ApacheTomcat是由Apache软件基金会属下Jakarta项目开发的Servlet容器。攻击者可能可以构造恶意请求,造成反序列化代码执行漏洞。成功利用该漏洞需要同时满足下列四个条件:1. 攻击者能够控制服务器上文件的内容和名称;2. 服务器PersistenceManager配置中使用了FileStore;3. 服务器PersistenceManager配置中设置了sessionAttributeValueClassNameFilter为NULL,或者使用了其他较为宽松的过滤器,允许攻击者提供反序列化数据对象;4. 攻击者知道使用的FileStore存储位置到可控文件的相对文件路径。


整体利用条件较为苛刻,实际危害相对较低,为彻底防止漏洞潜在风险,安全狗应急响应中心仍建议Apache Tomcat用户修复漏洞。

官方目前已经发布安全补丁,请参照公告内容进行安装安全更新补丁。

Apache Tomcat 10.0.0-M5:

https://tomcat.apache.org/download-10.cgi

Apache Tomcat 9.0.35:

https://tomcat.apache.org/download-90.cgi

Apache Tomcat 8.5.55:

https://tomcat.apache.org/download-80.cgi

Apache Tomcat 7.0.104:

https://tomcat.apache.org/download-70.cgi不方便升级的用户,可以采取如下临时措施缓解漏洞利用:禁止使用Seesion持久化功能FileStore

发表评论