首页 » 安全预警 » 正文

【高危安全通告】Apache Spark 远程代码执行漏洞

近日,安全狗运营中心监测到,ApacheSpark发布安全更新公告,披露了Spark2.4.5和更早版本中存在的远程代码执行漏洞(CVE-2020-9480),攻击者可利用该漏洞远程启动Spark集群上的应用程序资源,从而造成任意命令执行。

为避免您的业务受影响,安全狗建议您及时开展安全自查,如在受影响范围,请您及时进行更新修复,避免被外部攻击者入侵。

Apache Spark 是专为大规模数据处理而设计的快速通用的计算引擎。Apache Spark独立资源管理器的主服务器可以通过配置共享密钥进行认证(spark.authenticate),由于Spark的认证机制存在缺陷,导致在认证启用之后,攻击者即使没有共享密钥,也可以通过发送精心构造的远程过程调用指令到主服务器,进而在Spark集群上成功启动应用程序的资源。

官方目前已经发布安全补丁,请参照公告内容进行安装安全更新补丁。

建议用户更新到Spark 2.4.6或3.0.0以上版本  

下载地址:https://github.com/apache/spark/releases

【备注】:建议您在安装补丁前做好数据备份工作,避免出现意外

发表评论